web/security: add 2.0.4