libavcodec/version: add a comment about FF_API_MPV_OPT deprecation
[ffmpeg.git] / libavcodec / version.h
index 1d4e5df..8584bb7 100644 (file)
 #ifndef FF_API_AVCTX_TIMEBASE
 #define FF_API_AVCTX_TIMEBASE    (LIBAVCODEC_VERSION_MAJOR < 59)
 #endif
-#ifndef FF_API_MPV_OPT
-#define FF_API_MPV_OPT           (LIBAVCODEC_VERSION_MAJOR < 59)
+#ifndef FF_API_MPV_OPT /* To be removed with ffserver removal */
+#define FF_API_MPV_OPT           1
 #endif
 #ifndef FF_API_STREAM_CODEC_TAG
 #define FF_API_STREAM_CODEC_TAG  (LIBAVCODEC_VERSION_MAJOR < 58)