aarch64: vp9: Fix assembling with Xcode 6.2 and older
authorMemphiz <memphis@machzwo.de>
Sun, 18 Jun 2017 10:30:16 +0000 (12:30 +0200)
committerMartin Storsjö <martin@martin.st>
Tue, 20 Jun 2017 13:14:03 +0000 (16:14 +0300)
commita970f9de865c84ed5360dd0398baee7d48d04620
tree8f4063bd556486acdca2a4477e8e26da5249c726
parentc5c76370ae240b5e451c4a00a7ab485c0c0e0e98
aarch64: vp9: Fix assembling with Xcode 6.2 and older

Properly use the b.eq/b.ge forms instead of the nonstandard forms
(which both gas and newer clang accept though), and expand the
register list that used a range (which the Xcode 6.2 clang, based
on clang 3.5 svn, didn't support).

Signed-off-by: Martin Storsjö <martin@martin.st>
libavcodec/aarch64/vp9itxfm_neon.S
libavcodec/aarch64/vp9mc_neon.S