openssl: Allow newer TLS versions than TLSv1
authorMark Thompson <sw@jkqxz.net>
Fri, 28 Oct 2016 18:50:27 +0000 (19:50 +0100)
committerMark Thompson <sw@jkqxz.net>
Sun, 30 Oct 2016 13:18:45 +0000 (13:18 +0000)
commite8634fb92e2f624f19ee5fced6481d8ece503119
tree78b0a35f5ac418f6c201fcb66a7ddb4a7113af0a
parent121be310607879841d19a34d9f16d4fe9ba7f18c
openssl: Allow newer TLS versions than TLSv1

The use of TLSv1_*_method() disallows newer protocol versions; instead
use SSLv23_*_method() and then explicitly disable the deprecated
protocol versions which should not be supported.

Fixes ticket #5915.
libavformat/tls_openssl.c