configure: warn if GCC 4.2 is being used
authorGanesh Ajjanagadde <gajjanagadde@gmail.com>
Wed, 26 Aug 2015 13:36:25 +0000 (09:36 -0400)
committerCarl Eugen Hoyos <cehoyos@ag.or.at>
Thu, 27 Aug 2015 14:56:34 +0000 (16:56 +0200)
The wiki, Ticket1464, and Ticket3970 warn about the usage of GCC 4.2.
This fixes Ticket3970.

Signed-off-by: Ganesh Ajjanagadde <gajjanagadde@gmail.com>
configure

index a9940f6..0c3794b 100755 (executable)
--- a/configure
+++ b/configure
@@ -3542,6 +3542,7 @@ tms470_flags(){
 probe_cc(){
     pfx=$1
     _cc=$2
+    first=$3
 
     unset _type _ident _cc_c _cc_e _cc_o _flags _cflags
     unset _ld_o _ldflags _ld_lib _ld_path
@@ -3567,6 +3568,12 @@ probe_cc(){
         case $gcc_basever in
             2*) _depflags='-MMD -MF $(@:.o=.d) -MT $@' ;;
         esac
+        if [ "$first" = true ]; then
+            case $gcc_basever in
+                4.2*)
+                warn "gcc 4.2 is outdated and may miscompile FFmpeg. Please use a newer compiler." ;;
+            esac
+        fi
         _cflags_speed='-O3'
         _cflags_size='-Os'
     elif $_cc --version 2>/dev/null | grep -q ^icc; then
@@ -3729,7 +3736,7 @@ set_ccvars(){
     fi
 }
 
-probe_cc cc "$cc"
+probe_cc cc "$cc" "true"
 cflags_filter=$_flags_filter
 cflags_speed=$_cflags_speed
 cflags_size=$_cflags_size