doc/faq: remove "-profile option fails when encoding H.264 video with AAC audio"...
authorStefano Sabatini <stefasab@gmail.com>
Fri, 3 Jan 2014 12:38:49 +0000 (13:38 +0100)
committerStefano Sabatini <stefasab@gmail.com>
Fri, 3 Jan 2014 16:05:44 +0000 (17:05 +0100)
The error was fixed in commit ce9bd303794fcc94aa232c116bece13c5994b55b
more than one year ago, and does not affect all the currently supported
versions.

In particular, fix trac issue #1535.

doc/faq.texi

index c47d9d9..74c259f 100644 (file)
@@ -368,26 +368,6 @@ ffmpeg -f u16le -acodec pcm_s16le -ac 2 -ar 44100 -i all.a \
 rm temp[12].[av] all.[av]
 @end example
 
-@section -profile option fails when encoding H.264 video with AAC audio
-
-@command{ffmpeg} prints an error like
-
-@example
-Undefined constant or missing '(' in 'baseline'
-Unable to parse option value "baseline"
-Error setting option profile to value baseline.
-@end example
-
-Short answer: write @option{-profile:v} instead of @option{-profile}.
-
-Long answer: this happens because the @option{-profile} option can apply to both
-video and audio.  Specifically the AAC encoder also defines some profiles, none
-of which are named @var{baseline}.
-
-The solution is to apply the @option{-profile} option to the video stream only
-by using @url{http://ffmpeg.org/ffmpeg.html#Stream-specifiers-1, Stream specifiers}.
-Appending @code{:v} to it will do exactly that.
-
 @section Using @option{-f lavfi}, audio becomes mono for no apparent reason.
 
 Use @option{-dumpgraph -} to find out exactly where the channel layout is