doc/APIchanges: Add 4.0 cut point