doc/APIchanges: Add 3.4 cut point