configure: Use require_pkg_config for Speex