More explicit OpenSSL check
authorhyc <hyc@400ebc74-4327-4243-bc38-086b20814532>
Sat, 24 Apr 2010 23:19:14 +0000 (23:19 +0000)
committerhyc <hyc@400ebc74-4327-4243-bc38-086b20814532>
Sat, 24 Apr 2010 23:19:14 +0000 (23:19 +0000)
git-svn-id: svn://svn.mplayerhq.hu/rtmpdump/trunk@450 400ebc74-4327-4243-bc38-086b20814532

librtmp/handshake.h

index df563c0..93b6f16 100644 (file)
@@ -43,8 +43,8 @@ typedef gcry_cipher_hd_t      RC4_handle;
 #include <openssl/sha.h>
 #include <openssl/hmac.h>
 #include <openssl/rc4.h>
-#if OPENSSL_VERSION_NUMBER < 0x0090800
-#error Your OpenSSL installation is too old, need 0.9.8 or newer
+#if OPENSSL_VERSION_NUMBER < 0x0090800 || !defined(SHA256_DIGEST_LENGTH)
+#error Your OpenSSL is too old, need 0.9.8 or newer with SHA256
 #endif
 #define HMAC_setup(ctx, key, len)      HMAC_CTX_init(&ctx); HMAC_Init_ex(&ctx, key, len, EVP_sha256(), 0)
 #define HMAC_crunch(ctx, buf, len)     HMAC_Update(&ctx, buf, len)