Remove gcc_fixes.h. It only contains workarounds for unsupported gcc versions.
[ffmpeg.git] / libavcodec / ppc / idct_altivec.c
index 19cc93a..6043a17 100644 (file)
 
 #include <stdlib.h>                                      /* malloc(), free() */
 #include <string.h>
+#include "config.h"
+#if HAVE_ALTIVEC_H
+#include <altivec.h>
+#endif
 #include "libavcodec/dsputil.h"
-
-#include "gcc_fixes.h"
 #include "types_altivec.h"
 #include "dsputil_ppc.h"