configure: warn about disabled explicitly enabled components
authorMarton Balint <cus@passwd.hu>
Mon, 28 Jan 2019 00:49:46 +0000 (01:49 +0100)
committerMarton Balint <cus@passwd.hu>
Mon, 11 Feb 2019 21:01:48 +0000 (22:01 +0100)
commit0c3333faf6b7bfd45ce666ae697759d9239ba587
tree92a33b1dc39c4d38855f8e518f8cb00a76d32b8a
parentaa25198f1b925a464bdfa83a98476f08d26c9209
configure: warn about disabled explicitly enabled components

If we enable a component but a dependant library is disabled, then the enabled
component gets silently disabled. Warning about disabled explicitly enabled components
allows configure to show the missing dependencies and if --fatal-warnings is
used it can also fail if the user wants it so.

For example if libdav1d is not availble ./configure --enable-decoder=libdav1d
succeeds but the libdav1d decoder is not be enabled. After the patch configure
will warn about this:

WARNING: Disabled libdav1d_decoder because not all dependencies are satisfied: libdav1d

Signed-off-by: Marton Balint <cus@passwd.hu>
configure