AltiVec code and runtime cpudetect do not require CONFIG_GPL.
authorDiego Biurrun <diego@biurrun.de>
Thu, 25 Jun 2009 20:06:03 +0000 (20:06 +0000)
committerDiego Biurrun <diego@biurrun.de>
Thu, 25 Jun 2009 20:06:03 +0000 (20:06 +0000)
commit8b1a64417751936a89365b31a0a0dd793b855ba6
treefad2e97c33c7dd39045a1000dc2fe2dd94f3ce6a
parent1cd44221634f2ca8a10b8851f7cd0f4efff1fb3e
AltiVec code and runtime cpudetect do not require CONFIG_GPL.
Make sure the latter is only checked for x86 optimizations, which are GPL.

Originally committed as revision 29390 to svn://svn.mplayerhq.hu/mplayer/trunk/libswscale
libswscale/swscale.c