avcodec/utils: Enforce minimum width also for VP5/6
authorMichael Niedermayer <michael@niedermayer.cc>
Wed, 11 Apr 2018 17:50:52 +0000 (19:50 +0200)
committerMichael Niedermayer <michael@niedermayer.cc>
Mon, 9 Jul 2018 23:52:55 +0000 (01:52 +0200)
commit9af1e014f788a9c8700c4415130475f27a35e3db
tree4b646223384ac9056ea76a1efdf4cb7a3cfe92cf
parent6186bfad387042f36a6fbf7c38dafaeec6cc774a
avcodec/utils: Enforce minimum width also for VP5/6

Fixes: out of array access
Fixes: poc_0411

Found-by: GwanYeong Kim <gy741.kim@gmail.com>
Tested-by: GwanYeong Kim <gy741.kim@gmail.com>
Signed-off-by: Michael Niedermayer <michael@niedermayer.cc>
(cherry picked from commit 544324827e0131e43af1a54fb790a48a25fd7ba4)
Signed-off-by: Michael Niedermayer <michael@niedermayer.cc>
libavcodec/utils.c