avcodec/ffv1enc: Check that the crc + version combination is supported
authorMichael Niedermayer <michael@niedermayer.cc>
Sat, 21 Apr 2018 20:19:31 +0000 (22:19 +0200)
committerMichael Niedermayer <michael@niedermayer.cc>
Sun, 17 Jun 2018 23:16:04 +0000 (01:16 +0200)
commitbe9c4cc0e60a2e7cecd25d9c78d4f11aba274620
treea17beec376808f4ad2f6677f44b86b3595768633
parent1d5694ba1101e6d26f15909eee0d10c6a4fe55c3
avcodec/ffv1enc: Check that the crc + version combination is supported

The crc flag is only stored since version 3 thus before this crcs do not
work. We increase the version as needed same as we do with pix_fmts

Signed-off-by: Michael Niedermayer <michael@niedermayer.cc>
(cherry picked from commit d9706f79c17a33bf97e51a7d6ab211ce83a463ee)
Signed-off-by: Michael Niedermayer <michael@niedermayer.cc>
libavcodec/ffv1enc.c