Use proper library versions instead of SPPVERSION in Darwin SHFLAGS.
authorDiego Biurrun <diego@biurrun.de>
Wed, 12 Mar 2008 19:27:24 +0000 (19:27 +0000)
committerDiego Biurrun <diego@biurrun.de>
Wed, 12 Mar 2008 19:27:24 +0000 (19:27 +0000)
Originally committed as revision 12423 to svn://svn.ffmpeg.org/ffmpeg/trunk

configure

index f6f4e4c..4bea320 100755 (executable)
--- a/configure
+++ b/configure
@@ -1200,7 +1200,7 @@ case $targetos in
         ;;
     darwin)
         disable need_memalign
-        SHFLAGS='-dynamiclib -Wl,-single_module -Wl,-install_name,$(SHLIBDIR)/$(SLIBNAME),-current_version,$(SPPVERSION),-compatibility_version,$(SPPVERSION) -Wl,-read_only_relocs,suppress'
+        SHFLAGS='-dynamiclib -Wl,-single_module -Wl,-install_name,$(SHLIBDIR)/$(SLIBNAME),-current_version,$(LIBVERSION),-compatibility_version,$(LIBMAJOR) -Wl,-read_only_relocs,suppress'
         VHOOKSHFLAGS='-dynamiclib -Wl,-single_module -flat_namespace -undefined suppress -Wl,-install_name,$(SHLIBDIR)/vhook/$@'
         strip="strip -x"
         FFLDFLAGS="-Wl,-dynamic,-search_paths_first"