configure: openssl is compatible with the LGPL.
authorMichael Niedermayer <michaelni@gmx.at>
Mon, 28 May 2012 13:36:35 +0000 (15:36 +0200)
committerMichael Niedermayer <michaelni@gmx.at>
Wed, 6 Jun 2012 22:55:23 +0000 (00:55 +0200)
looking at the license i cannot see why they would be incompatible and
researching this matter a bit also turned up no reasons.

If i missed something, please dont hesitate to flame me and or revert

Signed-off-by: Michael Niedermayer <michaelni@gmx.at>
(cherry picked from commit f997ac1c8bc2124c4c6bf33ad17bc6f6cca0f84e)

Signed-off-by: Michael Niedermayer <michaelni@gmx.at>
configure

index 89098fd..8718ff6 100755 (executable)
--- a/configure
+++ b/configure
@@ -2862,7 +2862,7 @@ die_license_disabled gpl x11grab
 
 die_license_disabled nonfree libaacplus
 die_license_disabled nonfree libfaac
-die_license_disabled nonfree openssl
+enabled gpl && die_license_disabled nonfree openssl
 
 die_license_disabled version3 libopencore_amrnb
 die_license_disabled version3 libopencore_amrwb