mingw: don't check for minimum mingw runtime and w32api versions for mingw-w64
authorRamiro Polla <ramiro.polla@gmail.com>
Tue, 27 Jan 2009 20:03:22 +0000 (20:03 +0000)
committerRamiro Polla <ramiro.polla@gmail.com>
Tue, 27 Jan 2009 20:03:22 +0000 (20:03 +0000)
there is no vfw in mingw-64, and it has different (not yet stable) version
defines

Originally committed as revision 16827 to svn://svn.ffmpeg.org/ffmpeg/trunk

configure

index f8054cf..f3fc16e 100755 (executable)
--- a/configure
+++ b/configure
@@ -1494,11 +1494,13 @@ case $target_os in
         SHFLAGS='-shared -Wl,--output-def,$$(@:$(SLIBSUF)=.def) -Wl,--enable-runtime-pseudo-reloc -Wl,--enable-auto-image-base'
         objformat="win32"
         enable dos_paths
+        if ! enabled x86_64; then
         check_cpp_condition _mingw.h "(__MINGW32_MAJOR_VERSION > 3) || (__MINGW32_MAJOR_VERSION == 3 && __MINGW32_MINOR_VERSION >= 15)" ||
             die "ERROR: MinGW runtime version must be >= 3.15."
         enabled_any avisynth vfwcap_demuxer &&
             { check_cpp_condition w32api.h "(__W32API_MAJOR_VERSION > 3) || (__W32API_MAJOR_VERSION == 3 && __W32API_MINOR_VERSION >= 13)" ||
               die "ERROR: avisynth and vfwcap_demuxer require w32api version 3.13 or later."; }
+        fi
         ;;
     cygwin*)
         target_os=cygwin