configure: libnpp is always nonfree, even with LGPL
authorRicardo Constantino <wiiaboo@gmail.com>
Wed, 15 Mar 2017 22:47:58 +0000 (22:47 +0000)
committerJames Almer <jamrial@gmail.com>
Wed, 15 Mar 2017 22:53:12 +0000 (19:53 -0300)
libnpp was erroneously grouped up with libfdk-aac and openssl to check
if --enable-nonfree wasn't passed only with --enable-gpl in
9f28db47accb31bfec40a56dd2dc19ffd366a6be. The latter two are compatible
with LGPL, libnpp is not.

Signed-off-by: James Almer <jamrial@gmail.com>
configure

index e72ee297def8d2e91a8e3840388b857e3400ed9b..ecf67d5910049e34a63a57f184cc802e6c88f87a 100755 (executable)
--- a/configure
+++ b/configure
@@ -5173,7 +5173,8 @@ die_license_disabled_gpl() {
 map "die_license_disabled gpl"      $EXTERNAL_LIBRARY_GPL_LIST $EXTERNAL_LIBRARY_GPLV3_LIST
 map "die_license_disabled version3" $EXTERNAL_LIBRARY_VERSION3_LIST $EXTERNAL_LIBRARY_GPLV3_LIST
 
-enabled gpl && map "die_license_disabled_gpl nonfree" $EXTERNAL_LIBRARY_NONFREE_LIST $HWACCEL_LIBRARY_NONFREE_LIST
+enabled gpl && map "die_license_disabled_gpl nonfree" $EXTERNAL_LIBRARY_NONFREE_LIST
+map "die_license_disabled nonfree" $HWACCEL_LIBRARY_NONFREE_LIST
 
 enabled version3 && { enabled gpl && enable gplv3 || enable lgplv3; }