add a warning message for unsupported kind of encoding
authorAurelien Jacobs <aurel@gnuage.org>
Sat, 1 Sep 2007 13:04:25 +0000 (13:04 +0000)
committerAurelien Jacobs <aurel@gnuage.org>
Sat, 1 Sep 2007 13:04:25 +0000 (13:04 +0000)
Originally committed as revision 10277 to svn://svn.ffmpeg.org/ffmpeg/trunk

libavcodec/vp6.c

index cfa7589..9b6a61f 100644 (file)
@@ -126,7 +126,9 @@ static int vp6_parse_header(vp56_context_t *s, uint8_t *buf, int buf_size,
             s->filter_selection = 16;
     }
 
-    vp56_rac_get(c);
+    if (vp56_rac_get(c))
+        av_log(s->avctx, AV_LOG_WARNING,
+               "alternative entropy decoding not supported\n");
 
     if (coeff_offset) {
         vp56_init_range_decoder(&s->cc, buf+coeff_offset,