Make more clear the error message for the libx264 version check.
authorStefano Sabatini <stefano.sabatini-lala@poste.it>
Sun, 19 Oct 2008 11:05:03 +0000 (11:05 +0000)
committerStefano Sabatini <stefano.sabatini-lala@poste.it>
Sun, 19 Oct 2008 11:05:03 +0000 (11:05 +0000)
Originally committed as revision 15645 to svn://svn.ffmpeg.org/ffmpeg/trunk

configure

index 00c44da..0e871d2 100755 (executable)
--- a/configure
+++ b/configure
@@ -1736,7 +1736,8 @@ enabled libschroedinger && add_cflags $(pkg-config --cflags schroedinger-1.0) &&
 enabled libtheora  && require  libtheora theora/theora.h theora_info_init -ltheora -logg
 enabled libvorbis  && require  libvorbis vorbis/vorbisenc.h vorbis_info_init -lvorbisenc -lvorbis -logg
 enabled libx264    && require  x264 x264.h x264_encoder_open -lx264 -lm &&
-                      require_cpp_condition x264 x264.h "X264_BUILD >= 65"
+                      check_cpp_condition x264.h "X264_BUILD >= 65" ||
+                      die "ERROR: libx264 version must be >= 0.65."
 enabled libxvid    && require  Xvid xvid.h xvid_global -lxvidcore
 enabled mlib       && require  mediaLib mlib_types.h mlib_VectorSub_S16_U8_Mod -lmlib