configure: use pkg-config to detect libbluray
authorTimothy Gu <timothygu99@gmail.com>
Mon, 24 Feb 2014 00:39:18 +0000 (16:39 -0800)
committerTimothy Gu <timothygu99@gmail.com>
Fri, 7 Mar 2014 01:56:28 +0000 (17:56 -0800)
The current configure fails when static libbluray is compiled with libxml2
support.

Signed-off-by: Timothy Gu <timothygu99@gmail.com>
Signed-off-by: Michael Niedermayer <michaelni@gmx.at>
(cherry picked from commit baa650cc7946a9eb1cf5a083f61a581a97122f03)
Signed-off-by: Timothy Gu <timothygu99@gmail.com>
Conflicts:
configure

configure

index 71396b2..88e14f4 100755 (executable)
--- a/configure
+++ b/configure
@@ -3637,7 +3637,7 @@ enabled gnutls     && require_pkg_config gnutls gnutls/gnutls.h gnutls_global_in
 enabled libiec61883 && require libiec61883 libiec61883/iec61883.h iec61883_cmp_connect -lraw1394 -lavc1394 -lrom1394 -liec61883
 enabled libaacplus && require  "libaacplus >= 2.0.0" aacplus.h aacplusEncOpen -laacplus
 enabled libass     && require_pkg_config libass ass/ass.h ass_library_init
-enabled libbluray  && require libbluray libbluray/bluray.h bd_open -lbluray
+enabled libbluray  && require_pkg_config libbluray libbluray/bluray.h bd_open
 enabled libcelt    && require libcelt celt/celt.h celt_decode -lcelt0 &&
                       { check_lib celt/celt.h celt_decoder_create_custom -lcelt0 ||
                         die "ERROR: libcelt must be installed and version must be >= 0.11.0."; }