configure: Add missing xlib dependency for VAAPI X11 code