flvdec: require need_context_update when changing codec id