Replace hackish support for amr-nb and amr-wb. Instead of including the source