update to libnut API, non-negative errors